如何在wamp中集成PHP5.5

今天因为要用oauth,php5.4 x64的没有配套的dll,所以 研究下如何在wamp中加入php5.5。

因为wamp官网没有php5.5的附加包。然后 我们认为肯定只要放入php后配置某些文件就可以了。php->version中就会多出一个php5.5的选项。

经过研究,终于知道如何将php5.5完美集成到wamp中了。

首先,php下载 php5.5(http://windows.php.net/download/) 注意: 要对应你 的apache 版本,我们找的是对应apache 2.4.2的ts版 x64 php5.5。 解压到 wamp\bin\php\下改名php5.5.13

然后 将自带php5.4.12的phpForApache.ini

和wampserver.conf 拷贝到php5.5.13中

最后修改 5.5中的 phpForApache.ini 那个里面的 ext 的路径

extension_dir = “c:/wamp/bin/php/php5.4.12/ext/”
改成自己对应的5.5的 就行了。

改完,退出wamp

重启进入 php-》version 里就会多出5.5的

如果前面有感叹号,说明哪里配置的路径有问题。

除非注明, 风波竹林 文章均为原创,转载请以链接形式标明本文地址
本文地址: https://blog.fbzl.org/如何在wamp中集成php5-5/

发表评论

电子邮件地址不会被公开。